Lucene Search Widget Doesn't Work

  1. Avatar of Chinthaka

    I have configured the Lucene search module as described here (http://www.bettercms.com/documentation/setup-search-module). I am able to add both widgets to a page. But all the time when I search I am getting 'Showing 0 of 0 result(s) found for "first"' even though this word is exist several places.

    This is my configurations (added to the 'cms.config')

    <search> <add key="LuceneWebSiteUrl" value="http://localhost:50344/" /> <add key="LuceneFileSystemDirectory" value="~/LuceneIndex" /> <add key="LuceneIndexerFrequency" value="00:01:00" /> <add key="LuceneIndexerPageFetchTimeout" value="00:01:00" /> <add key="LucenePagesWatcherFrequency" value="00:01:00" /> <add key="LuceneMaxPagesPerQuery" value="1000" /> <add key="LucenePageExpireTimeout" value="00:00:00" /> <add key="LuceneDisableStopWords" value="true" /> <add key="LuceneSearchForPartOfWords" value="true" /> <add key="LuceneIndexPrivatePages" value="true" /> <add key="LuceneAuthorizationUrl" value="http://localhost:50344/login" /> <add key="LuceneAuthorizationForm.UserName" value="admin" /> <add key="LuceneAuthorizationForm.Password" value="admin" /> <add key="LuceneAuthorizationForm.RememberMe" value="true" /> </search>

    I have two questions. 1. Can anyone please let me know how to overcome this issue? 2. Is there a way to customize the search such as search similar word or part of a word etc..?
    Thanks

  2. Avatar of Chinthaka

    I am able to get some search results. This started to work after change the page category to 'Search'. The search result is as follows.

    Contact Us /contact-us/

    ... QUICK SEARCH FORM --> Menu Default page First Page Forth Page Sub Page Search First blog Contact Us Product <!-- END SIDEBAR MENU --> <!-- END SIDEBAR --> <!-- BEGIN CONTENT --> About Us about us page... Product /product/

    ... QUICK SEARCH FORM --> Menu Default page First Page Forth Page Sub Page Search First blog Contact Us Product <!-- END SIDEBAR MENU --> <!-- END SIDEBAR --> <!-- BEGIN CONTENT --> About Us about us page...

    Why does is search the HTML content ? Does this has to be search 'Pages' table ?

  3. Avatar of Chinthaka

    For anyone who might came across same issue.

    I found this.

    https://github.com/devbridge/BetterCMS/issues/1175

    It seems like this is a bug and hoping some one will fix the issue soon.

* Mandatory
* Mandatory
* Mandatory

Verify that you are human