Install Package Error for Better CMS 2.0.3

  1. Avatar of JT

    It looks like the installer package is referencing 2 different versions of NHibernate; it throws the following error:

    PM> Install-Package BetterCMS Attempting to resolve dependency 'BetterCms.Core (= 2.0.3)'. Attempting to resolve dependency 'Autofac (≥ 3.1.5)'. Attempting to resolve dependency 'BetterModules.Core (= 1.0.0)'. Attempting to resolve dependency 'Common.Logging (≥ 2.1.2)'. Attempting to resolve dependency 'FluentMigrator (= 1.0.6.0)'. Attempting to resolve dependency 'FluentMigrator.Tools (= 1.0.6.0)'. Attempting to resolve dependency 'FluentNHibernate (= 1.3.0.733)'. Attempting to resolve dependency 'NHibernate (≥ 3.3.1.4000)'. Attempting to resolve dependency 'Iesi.Collections (≥ 3.2 && < 4.0)'. Attempting to resolve dependency 'Iesi.Collections (≥ 3.3.1.4000)'. Attempting to resolve dependency 'NHibernate (= 3.3.3.4001)'. Install-Package : Already referencing a newer version of 'NHibernate'. At line:1 char:16 + Install-Package <<<< BetterCMS + CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

    Is there any way around this?

  2. Avatar of Simonas

    Try first to install NHibernate:

    Install-Package NHibernate -Version 3.3.3.4001
    

    then:

    Install-Package BetterCMS
    
  3. Avatar of JT

    Worked perfectly. Thank you!

  4. Avatar of Niraj Singh

    Facing the issue while following the above steps

    Install-Package : Already referencing a newer version of 'NHibernate'. At line:1 char:1 + Install-Package BetterCMS + ~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

  5. Avatar of Harry

    I'm Facing this below issue when installing "Install-Package BetterCMS"

    PM> Install-Package BetterCMS Attempting to resolve dependency 'BetterCms.Core (= 2.0.3)'. Attempting to resolve dependency 'Autofac (≥ 3.1.5)'. Attempting to resolve dependency 'BetterModules.Core (= 1.0.0)'. Attempting to resolve dependency 'Common.Logging (≥ 2.1.2)'. Attempting to resolve dependency 'FluentMigrator (= 1.0.6.0)'. Attempting to resolve dependency 'FluentMigrator.Tools (= 1.0.6.0)'. Attempting to resolve dependency 'FluentNHibernate (= 1.3.0.733)'. Attempting to resolve dependency 'NHibernate (≥ 3.3.1.4000)'. Attempting to resolve dependency 'Iesi.Collections (≥ 3.2 && < 4.0)'. Attempting to resolve dependency 'Iesi.Collections (≥ 3.3.1.4000)'. Attempting to resolve dependency 'NHibernate (= 3.3.3.4001)'. Install-Package : Already referencing a newer version of 'NHibernate'. At line:1 char:16 + Install-Package <<<< BetterCMS + CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

  6. Avatar of Bhavdip

    thanks

  7. Avatar of MAK

    Install-Package : Already referencing a newer version of 'NHibernate'. At line:1 char:1 + Install-Package BetterCMS + ~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

  8. Avatar of Tanya

    Install-Package : Already referencing a newer version of 'NHibernate'. At line:1 char:16 + Install-Package <<<< BetterCMS + CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

    -- install-package BetterCMS gives above error.

    I have created a MVC4 Intranet application. .NET4.5

    Tried options mentioned above to fix the error but dint help. Please assist if you can.

  9. Avatar of Tanya

    Update as of 1-15-2018: I had to upgrade Nuget itself from 2.0 to 2.8 and after that i tried installing bettercms plugin and itworked like a charm! So upgrading Nuget fixed the below error for me: PM> Install-Package BetterCMS Attempting to resolve dependency 'BetterCms.Core (= 2.0.3)'. Attempting to resolve dependency 'Autofac (≥ 3.1.5)'. Attempting to resolve dependency 'BetterModules.Core (= 1.0.0)'. Attempting to resolve dependency 'Common.Logging (≥ 2.1.2)'. Attempting to resolve dependency 'FluentMigrator (= 1.0.6.0)'. Attempting to resolve dependency 'FluentMigrator.Tools (= 1.0.6.0)'. Attempting to resolve dependency 'FluentNHibernate (= 1.3.0.733)'. Attempting to resolve dependency 'NHibernate (≥ 3.3.1.4000)'. Attempting to resolve dependency 'Iesi.Collections (≥ 3.2 && < 4.0)'. Attempting to resolve dependency 'Iesi.Collections (≥ 3.3.1.4000)'. Attempting to resolve dependency 'NHibernate (= 3.3.3.4001)'. Install-Package : Already referencing a newer version of 'NHibernate'. At line:1 char:16 + Install-Package <<<< BetterCMS + CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

* Mandatory
* Mandatory
* Mandatory

Verify that you are human